Help

System Requirements for Computers

Learn about the system requirements for watching Prime Video through your computer's web browser.

Computer Hardware

Intel Core 2 Duo Processor (or equivalent)

Computer Operating System

  • Windows 7 or newer
  • Mac OS 10.7 or newer
  • You can use Chrome to watch Prime Video on Linux/UNIX operating systems (including Chrome OS).

Internet Connection

  • Standard Definition (SD) videos: 900 Kbits/sec
  • High Definition (HD) videos: 3.5 Mbits/sec

Note: Prime Video streaming is not supported through Virtual Private Network (VPN) or proxy connections. To watch Prime Video, you'll need to disable these services for your device or try switching to another available connection.

Web Browsers

  • Chrome (latest version)
  • Firefox (latest version)
  • Internet Explorer (latest version)
  • Microsoft Edge
  • Safari (latest version)
  • Opera (latest version)

Note: Firefox ESR is not supported at this time. Firefox ESR (Version 60) will be supported when it's available for the general public, which is approximately May 1, 2018.

Tip: To watch Prime Video on your computer, we recommend using a browser that supports our HTML5 video player. The HTML5 player is optimized to work with the Prime Video service, and doesn't use separate browser plugins to play video content. It also supports video features like Auto Play and playback in full 1080p High Definition.

The HTML5 player is supported on:

  • Chrome (latest version)
  • Firefox (latest version)
  • Internet Explorer (latest version on Windows 8.1 and later)
  • Microsoft Edge on Windows 10
  • Opera (latest version)
  • Safari (latest version on macOS 10.12.1 and later)

Browser Plug-ins

If you use a browser or browser version that does not support our HTML5 player, you can access Prime Video with Microsoft Silverlight.

Silverlight is a browser plugin used to play Prime Video content on Safari and some versions of Internet Explorer. You'll typically see an on-screen installation or activation prompt if Silverlight is required for your browser.

The minimum supported version of Silverlight is 5.1.

Tip: If you're having trouble activating Silverlight, check to make sure that your browser's Add-ons or Plugin preferences are not set to "Never Activate" Silverlight. To access Silverlight from your browser, you may need to change these settings to "Ask to Activate" or "Always Activate."

Related Help Topics